REQUIREMENTS - SECURITY

■ About the system requirements ■

Internet Explorer 6.0 or higher is required to watch this website.
It is also possible to use earlier versions,? however this is not recommended, since the website’s content might not be displayed in proper style.

This goes for Windows OS only. As for Macintosh Web browsers, different requirements might be necessary.

This site’s contents includes FLASH movies. To see them, the latest FLASH player is needed.
If you don’t have the latest FLASH player, please install it from the icon below.

flashplayer